Safari Autofill


First of all, I'm sorry if this question has already been discussed. I didn't find an answer on it in the forum.
When I'm using Better Touch Bar with Safari and when I need to fill a password, no problem, the TouchId takes the hand on Better Touch Bar. But, this is not the same behavior when I'm in a webform where I have to fill my email, address, zip code, etc. The autofill of webform was, until I discovered Better Touch Bar, the only real value of my Touch Bar so, it's quite annoying to not have it anymore :frowning:

unfortunately it's not possible to mix native and BTT Touchbar elements.

You can however disable the BTT Touch Bar for Safari

Thanks for your answer !

I found an alternative : I'added a button to quit the BetterTouchTool. So If I have to fill a webform I quit BetterTouchTool and relaunch it quickly with the dock. Quite acceptable as workaround.

I know your pain, I feel the same.
My advice though would be to trigger the Touch Bar with a Trackpad shortcut (I use a two finger force click to enable/disable the Touch Bar in my Preset) as you can use the same action when you start and stop using the native bar - it also allows you to make the icon disappear from the dock :wink:

Another way would be to disable BTT when some keys are pressed (⌃⌥ in my example).
J'espère que ça aide! :slightly_smiling_face:

Good idea ! This workaround is better than mine ! thanks for it !

1 Like