Restart loop on my new 2018 MBP

Describe the bug
When I start BTT it runs through the 3 screens of "data privacy", "usage & crashlog collection" and "now ready to use", but clicking on the "Start using BTT and open preferences" takes me back to the start again.

If I close one of the windows BTT will launch but some things like move and resizing options are forgotten.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
BTT in general.

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2018 MBP
  • macOS version: 10.13.6
  • BetterTouchTool version: 2.636

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

sounds like a file permission problem (BTT seems to be unable to write to its data files).

Did you maybe restore the BTT settings using a time machine backup?

I had to rename my username (IT got it wrong on my new machine).

How do I get out of this?
I have already tried reinstalling BTT to no avail.

I would try to delete this file while BTT is not running:
~/Library/Preferences/com.hegenberg.BetterTouchTool.plist

(the ~ means "yourusername", to open the preferences folder use Finder => Go => Go To Folder and enter "~/Library/Preferences/")

That did the trick, thx.

Didn't do the trick for me. I too got this after I changed my username on the machine, but I removed all mentions of BTT preferences and it still happens.

the log is not very informative, but running from the commandline gave a clue:

=> /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool
objc[43784]: Class SSKeychain is implemented in both /System/Library/PrivateFrameworks/StoreServices.framework/Versions/A/StoreServices (0x7fffad53a7f8) and /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool (0x110594660). One of the two will be used. Which one is undefined.
CoreData: annotation:  Failed to load optimized model at path '/Applications/BetterTouchTool.app/Contents/Resources/BetterTouchTool_DataModel.momd/BetterTouchTool_DataModel 61.omo'

the file is there and is world readable. btw, only *.omo in a directory of *.mom. is that right?

Imprint | Privacy Policy