Presetgestures is not valid

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac: M1 MBP
  • macOS version: Ventura Boulevard
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
    Not sure what this is but it's hard to stop it popping up over and over again. Just appeared in the latest alpha I believe.

Unfortunately it sounds like your BetterTouchTool database got corrupted for some reason.

I'd recommend to create a backup of this folder: ~/Library/Application Support/BetterTouchTool (go there via Finder => Go => Go to Folder, make sure to include the ~).
Then quit BTT and delete these three files from the folder:


Afterwards BTT should try to use the database from the previous version again. If the old one is still intact it should then work again,.