Possible BUG? Apple Script Current date widget is inserting "name:" between each letter?

edit: Walked away for an hour and it's back to normal.

I'm on version 3.157 on Mojave 10.14.5
I'm not sure what is going on here. Up until earlier today this widget was working fine. Only thing I changed was adding an Airpods widget, but deleting that doesn't fix this. My widget is supposed to show todays date with my next work shift beneath it. As seen on the right of this screen shot.

Instead this is what's showing up.

Running the script in BTT preferences shows the error now, but earlier when the error first showed up, it still showed the correct response:

"Mname:oname:n 22 Jname:uname:l
W: Thu 19.15"

Any idea why it's inserting "name:" between each letter?
This is the script I'm using:

set { weekday :wd, year:y, month :m, day:d, hours:hr, minutes:mm, seconds :sec} to current date
set wds to characters 1 thru 3 of (wd as text ) as string
set mon to characters 1 thru 3 of (m as text ) as string

if d < 10 then
set dayp to "0" & d as string
set dayp to d as string
end if

set datef to (wds & " " & dayp & " " & mon)

set nextwork to do shell script ("/usr/local/bin/icalBuddy -n -nrd -ea -nc -ps "|• |" -iep "datetime" -po "datetime" -ic "" & "Work" & "" -tf "%H.%M" -df "%a" -eed eventsToday+7 | head -n 1 | awk -F "• " '{print toupper(substr($2,1,1)) tolower(substr($2,2))" "$3}'")

set WorkDay to 1st word of nextwork
set WorkTime to last word of nextwork
set NW to "W: " & WorkDay & " " & WorkTime

return datef & "

" & NW

That's pretty weird. I don't think BTT could insert this itself.

Have you tried to restart your Mac?

Yeah. Mac restart was the second thing I tried. First was restarting BTT. Then I tried creating new widget, rewriting the script in a different way, trying just parts of it (ie just showing the month or day.) No idea why it started or why/how it fixed itself.