"Please Select a Trigger" brings up a series of nondescript GroupCell/Table View Cell choices

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

*When checking for Alpha Version Updates, I get the following message: *
You're up-to-date!
BetterTouchTool 3.936 is currently the newest version available.

I have restarted the system.

Describe the bug
A clear and concise description of what the bug is.

When selecting an existing gesture, or when adding a new gesture, clicking the "Please Select a Trigger" button brings up a selection window populated by a series of "GroupCell" expandable sections. Clicking (and expanding) a "GroupCell" opens up a series of choices labelled "Table View Cell". Underneath GroupCell --> Table View Cell are the familiar choices of 1, 2, 3 etc. fingers and associated options, but these choices only become visible and listed as the selected trigger once I make the "blind" choice.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad and Magic Trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 14 inch, 2021 (Apple M1 Pro chip)
  • macOS version: MacOS Ventura 13.0
  • BetterTouchTool version: Version: 3.936 (2101)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

You are using the old legacy UI which is not supported anymore. it hasn't been updated since 2018 and won't receive any fixes anymore. It's slowly breaking because of this and really should not be used anymore.


Thanks for the swift follow-up! The UI has been working with no issues until today, but I fully accept that keeping two different UIs running is not sustainable. I'll switch to the "new" UI.

Best regards,

I know what’s causing the issue - but it’s a bit hard to fix as the component got updated to be more flexible - which the old ui can’t handle anymore. Maybe I’ll be able to add a fallback version of the component.

However the old UI can also cause other problems, because the underlying data models have changed a lot since then. It can even corrupt data in some cases.

I fully understand.

Best regards,
PS. Thank you for all the hard work you've done to create (and continue to develop) a fantastic app!