One finger gestures not registered after a three-finger-tap

Describe the bug
After a three-finger-tap, one finger click and one finger tap can not be triggered until 1 sec pass.
This does not happen with four-finger-tap. That means you can use one finger tap "immediately" after a four-finger-tap, but cannot trigger it just after a three-finger-tap without about 1 sec of waiting.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Trackpad of Macbook pro 2018 with Touch Bar.

Device information:

  • Type of Mac: Macbook pro 2018 with Touch Bar
  • macOS version: 10.14.4
  • BetterTouchTool version: 2.819

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Cases I have tried:

  1. Disable BTT or quit it -> No bugs. (In order to verify that, Macbook allows users to trigger 1-finger gestures after a 3-finger-tap)
  2. Disable all gestures -> Bug exists. (Cannot even trigger normal 1-finger-click without waiting)
  3. Other gestures except for 1 finger ones works fine immediately after three-finger-tap.

Hope this is not a bug and there are some settings related to it, but I've tried various delay settings still couldn't fix the problem.

This is the demo video that shows this behavior:

First two tries are 3 finger tap -> 1 finger tap (repeat 1 finger tap until it is recognized)
3rd and 4th tries are 4 finger tap -> 1 finger tap
You can see the difference.
Why I reported this behavior is because I usually use 3 finger tap to open link in another tab of browser, and I use 1 finger tab at bottom to switch between tabs. So if I use 3 finger tap to open in another tab and wanna switch to it immediately, the first few 1 finger taps will not be recognized, which is quite annoying...

Is this a design decision for recognizing 4 finger gestures or double taps?
Should I live with it or is there any chance we can configure it in the settings?

sorry I'm currently a bit busy with other stuff, but I will look into this soon.