NsWorkSpace notifications often won't trigger

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Among others, I'm using these nsworkspace notification events:

And they often never trigger. If I just close the lid on my macbook for a few seconds, then opening it again, screensdidwake fires as intended. If I leave the computer sleeping for hours however, then open the lid, neither of didwake or screensdidwake fires correctly. Is this an issue with macOS or is it BTT doing something wrong?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)
No point with a screenshot

Device information:

  • Type of Mac: Macbook Pro 2016
  • macOS version: Mojave
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.560 (1700).

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Let me know what I can provide to help.

Just want to add my voice. I've done a lot of testing, such as putting the displays to sleep manually (Control Shift Eject) as well as just waiting for display to sleep after inactivity. These nsworkspace notifications hardly ever trigger for me.

Here I'm running Monterey on a MacBook Pro 2019.