Notification Name Not Saved By BTT 4.065 When "Received NSWorkspace Notification" Trigger Exported

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug

The issue I’m having is that I have a sequence of startup triggers that start Mountain Duck to mount an external volume that has my settings for Alfred.

When I exported my startup triggers, the name of the NSWorkspace notification ( that Mountain Duck posts was not exported into the .bttpreset file, as shown in these screenshots.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Mac Mini (M2 Pro)
  • macOS version: 13.2.1 (22D68)
  • BetterTouchTool version: 4.065

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Startup.bttpreset (2.9 KB)