Notch bar stopped working

I experienced minor issues with the notch bar over the past months, but overall it always worked just fine for me. Today all the buttons and folders suddenly disappeared, and the menu bar was moved from the mini area to its default size. I tried to restart BTT and my mac, but nothing worked. The status items widget is the only thing that works the way it used to. I have no idea what happened. I added a few app-specific buttons this morning and everything worked fine for a few hours. I left my mac on the table for a while, it went into sleep mode, and when I returned the notch bar was like this.

Macbook pro 14' with M1 pro chip
BTT 3.744
macOS Monterey 12.2.1

Edit: I tried to turn off some of the apps running in the background. After turning off Unclutter, AdGuard, TextSniper, Hazel, Alfred, and MacUpdater, the notch bar buttons suddenly reappeared. I turned the apps on again and everything seems to work for now

Very weird!

I'll be back on the Notch Bar development next week (we had our second baby in February and I took a few weeks off). If it happens again it would be great if you go to Help => Export Diagnostic Debug data and send the result to

Congrats! Take all the time you need. If it happens again, I will do as you suggested.

@Andreas_Hegenberg, this actually happened a few times since I posted, and it's still an issue with MacOS Monterey 12.3 and BTT 3.745. I sent you the debug files as you requested.

I noticed that AdGuard seems to be responsible. Turning it off and restarting BTT temporarily solves the issues