Not working on Adobe PDF

This is not the first time I wish to raise this topic.
I have tried it over and over again, trying to have this special app work in Adobe PDF files. It just wouldn't. Has anyone got a way to go about it?
It is an important tool. I am just trying to "Look up words under cursor" when reading pdf files. No matter the configuration I make, nothing happens in pdfs. I tried it with the trackpad 3 figure tap and the Magic Mouse middle Fingure tap. nothing works.
Using MackBook Pro
BetterTool version 4.314
everything is up to date.

Please help!

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):