new MBP and install of Mojave beta 10: window snapping not functioning

Describe the bug
Been using BTT for ages and window snapping always worked under high Sierra. Just bought a new MBP that had a fresh install of 10.13 and within days installed the latest beta of Mojave (18A384a). BTT works great as always but window snapping does nothing-no grids, no snapping, nothing. My prefs are unchanged and windows 7 style window resizing is enabled in the prefs. I have no custom snap areas.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro 2018 trackpad, Magic Trackpad 2

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Same with dragging to the top center-nothing happens

Device information:

  • Type of Mac: MacBook Pro 2018 with Touch Bar
  • macOS version: 10.14 18A384a
  • BetterTouchTool version: 2.635

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Restarted and nothing has changed.
Logs were sent via email (debug log)

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

mh seems to work fine here.

Could you maybe check whether 2.633 works?

You are sure you didn't accidentally disable window snapping by clicking the BTT menubar icon and choosing "disable BTT for..."

Never realized that happened! Sure enough, I guess it did. Now all is good. Thanks.