My computer is slow while Better touch tool is running.

Describe the bug
My computer is slow while Better touch tool is running.
After OS update to Big Sur, this happened.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Device information:

  • Type of Mac: MacBook Pro (16-inch, 2019)
  • macOS version: 11.2.1
  • BetterTouchTool version: 3.553

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Workaround: Stop Better Touch Tool.

If you have the experimental Dropbox or iCloud sync enabled in BTT, try to disable that.

1 Like

Hi Andreas,

Thanks for your reply and advices.
After kill Dropbox and iCloud sync or stuff like that, My computer is still slow with running BTT.
Do you have any advice for me?

I'll stop using BTT with this lag, even though I have used it for almost 5-6 years.
I love BTT but this lag causes making me dislike it actually.

Best regard.

Best regard.

Device information:

  • Type of Mac: MacBook Pro (16-inch, 2019, 16GB RAM)
  • macOS version: 11.2.3
  • BetterTouchTool version: 3.553 (1693).

I have exactly similar issue , with BTT 3.553 my MacBook Pro becomes sluggish and runs like a tortoise. everything in the system slows down dramatically. No response from Andreas even after sending two emails. When I quit the BTT , machine performance gets back to normal , I have observed the CPU usage is normal.

Disabled the iCloud Sync as well.

When I quit BTT my machine simply flies.

Have been with BTT now from few years now, love this utility but with Big Sur it is becoming a terrible experience.

Any solution let me know here.

I have the same issue, BTT has made my laptop unusable. Every 20-30 seconds CPU usage from BTT spikes the computer stops responding to keyboard inputs and clicks on the trackpad. I've disabled settings sync but this made no difference.

  • Type of Mac: MacBook Pro (16-inch, 2019, 16GB RAM)
  • macOS version: 11.2.1
  • BetterTouchTool version: 3.552

Here's an example of Activity Monitor, all the spikes are because of BTT, the computer is idle apart from that.

Screen Shot 2021-03-11 at 11.05.14

1 Like

Maybe some scripts you have regularly running in BTT?

If the experimental settings sync was enabled before you might need to delete your old preset and create a new one to resolve the issue. (Or better delete the whole ~/Library/Application Support/BetterTouchTool folder)

I have no scripts running. I updated the app to the latest version, deleted my preset and created a blank one and the problem still occurs.

If possible try to sample the BTT process using this terminal command while the issue occurs:

sample BetterTouchTool -file ~/Desktop/sample.txt

(it will save a file called sample.txt to your Desktop that you can send to )

Sadly that's impossible since the computer does not respond to input when the issue is occuring. I've tried removing the directory mentioned but it doesn't help, as soon as I go back to my old preset (Which has worked flawlessly since BTT was first released and is unchanged for several years) the issue comes back.

It's even to the point where even though I managed to start the sample command while the issue was occurring it hung without starting the sampling until after the CPU spike stopped.

So without your preset CPU is not spiking?
Possibly go to help => export diagnostic debug information and send the result (referencing this thread) to, then I can try your setup on my machine.

Email sent!

I didn't try without the preset for long enough to determine this, working without BTT was too much of a pain for me to be able to investigate for more than about 10 minutes :wink:

Just a quick update here , this morning I saw a BTT update which is now bumped upto 3.560 (1700) build . Post updating , the slowness of the Macbook has reduced to a large extent , I ma using Golden Chaos 3.392 Touch Bar integration as well , at times I get beachball for few seconds then everything gets back to normalcy. With this update there is a drastic improvement.

My BTT CPU Utilisation is to the tune of 0.3%.

The best utility for Mac just got better. I love using this Gem of a Application.

Will post back if find any bugs.

12/03/2021 - 19:21 GMT.

My excitement and enthusiasm short lived, after an hour of continuous usage the System was back to terrible speeds with many apps slowing down, only solution was to kill BTT to restore the performance.

Even Command Tab Application switcher was taking ages.

All Issues observed with the old build still persists with the newer build as well.

Any solution will be highly appreciated here..

@Andreas_Hegenberg - do we have an update here on when this bug will be fixed, it is seriously hampering the usage of the Mac on day to day tasks.

1 Like

Any one still facing this issue, with the latest release - 3.561 the symptoms of BTT slowing down the system has changed.

  1. When the Mac starts up everything is fine , the BTT will slowly start to slow the things out. Any and every other app becomes extremely slow.
  2. The only way to speed up the Mac is to quit the BTT and restart the computer.

Anyone facing a similar issue? Any fixes for this issue?

1 Like

My Expirience so far: Esspecially, when Keyboard Shortcuts come in handy I've to wait seconds, that my life goes further …

I have this problem too. My computer is so much faster without BTT. Still would like to keep using BTT, but at the moment I have to choose speed over BTT's added functions.

I'm a completely new mac user (1 month) but being a seasoned linux user (my longtime job was software engineer and systemist) i'm confident that what i found out, that is that BTT slows down the WindowServer process in my new M1 MacBook, is a fact.

I purchased a licensed BTT, mainly for using it with custom bar for Avid Sibelius, but i began to get bored by the micro-freezes that occur mainly in switching desktops and when scrolling in browsers.

So, i'm politely asking: is this sort of problem solvable? Or is a refund something that can be asked?


Suggestion for folks with this lag/slowdown problem. I've noticed this slowdown happen when I try to press the escape key while inside say VMware Fusion or VMware Horizon. In these instances, I can tell BetterTouchTool to disable itself when I am using those applications. Perhaps try similar?