Multiple Finger Swipe Trigger on Touchbar Lagging/Unresponsive and is resulting in ~60% CPU Usage While Performing Action

BTT Version: 3.571
System Details

This issue started a few weeks ago. Two finger swipe left and right to small step volume change (retrigger after sliding 1.4%) on the Touchbar has worked beautifully for the past year or so, until recently. Same story for three finger swipe to change small step brightness (retrigger after sliding 0.4%). I noticed my CPU is firing up to about 60% usage on all cores when the sliding action occurs. It is extremely unresponsive. The issue has persisted after multiple restarts, updates, and also persists when I switch from small step to regular and change the retrigger percentage.

do you maybe have some sort of recursion somewhere in your setup? Maybe a volume key in the keyboard shortcuts section in BTT that also triggers volume changes?

I don't believe so. I created a keyboard shortcut to change the volume, and I ran into the same issue when I executed that shortcut. When I use the standard volume slider widget on the Touchbar, the volume changes smoothly without taxing the CPU.

The issue stopped after I ran some basic maintenance tasks with Onyx, glad it is running smoothly again.

Imprint | Privacy Policy