Move Enter to F7 + disable Enter not working due to daisy chaining(?)

Due to repetitive strain injury (too much enter, delete, ", semicolon etc) I want to move e.g., the Enter key to F7 and disable the original Enter key. However, it seems like BBT rules are set to daisy chain, i.e., F7 goes to Enter which goes on to nothing (or whatever I set Enter to). Any way to say "change this key to that key and stop processing any more rules"?

Try this.

Shortcut: Enter = does nothing
Key Sequence: F7 = Insert custom text, Enter

Great, that works. Two things though:

  • define key sequence F7 = Enter first - if you disable Enter first you can't enter Enter😆
  • make sure to select "Insert text by typing", not "Insert text by pasting"

Thanks! Now it's just a matter of becoming used to it😆