Magic Trackpad 2 - Three Finger Swipes Recognized as multiple taps

Describe the bug
I have multiple swipe shortcuts set up for trackpads with three fingers, along with a shortcut for three finger tap. They work fine on my laptop trackpad (MB Air 2018), but on the Magic Trackpad 2, the swipes register as multiple 3 finger taps

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Magic Trackpad 2

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Air 2018
  • macOS version: 10.14.4
  • BetterTouchTool version: 2.809

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Nevermind, restarted the machine and it all works now!

Update: Restarting the Mac, BTT, or Disconnecting/reconnecting the trackpad works sometimes, but only temporarily. This is still an issue