MacOS menubar broken/black with "Widget Mode Test"

bettertouchtool: 3.897,2052 on macOS 12.6 21G115 arm64

This morning's update from homebrew broke my menubar. The new version asked for "Screen Recording" permission, which I granted; my menubar is now black with a red error message: "Widget Mode Test - Scroll Up/Down to switch modes. right click for more options." I don't know what that is, and don't recall using any "widget."?

Ah you might have experimented with the Notch bar before. You can disable that if you don't need it:

(Right click the menubar => Show BetterTouchTool Preferences)


Thanks! I dropped back to the version and the black/empty menubar was fixed. You are right that when looking at "notch bar" setting, that option was enabled, so I've disabled it, but I've yet to upgrade again. I rarely touch BTT settings and don't recall enabling that...? It's weird that this confusing behavior changes between minor versions in any case.

It shouldn’t change, but you are on the alpha channel and probably discovered a bug in the alpha version. I’ll try to reproduce this.

However BTT doesn’t really use the minor/minor/patch system, the version number doesn’t have a meaning apart from „bigger number = newer version“.

I didn't realize the homebrew cask was following alpha -- though I did wonder why I seemed to get a new version every few days. My use of BTT is super simple, so I'll just stick with a manually installed older version for now.

1 Like

I had the same issue

I had the same issue after updating BTT to 3.910 (stable) today. I was able to disable it by right clicking the black bar and selecting "disable". After that I disabled the Notch Bar feature completely in BTT preferences. I was using an external monitor when I encountered the issue.

1 Like

This should be resolved in 3.913 and higher.

I installed 3.913 and I'm still having the same issue.

only Siri remains visible on the right side of the menu bar.

If you had a version greater than 3.896 and lower or equal to 3.912 installed before, please go to the Notch Bar settings and disable the feature.

I don't believe I have ever changed the Notch setting before (and don't have a MacBook with a notch), but this was enabled for me. Disabling per the above fixed the issue.

I've also never touched the Notch setting before and do not own a Macbook with a notch.

Is it confused because I have an external monitor?

it was a bug, to get rid of it you can just disable the NotchBar feature in the settings

1 Like