Mac Catalina, mapping cursor keys to 5 6 7 8 keys not working

Hello, BTT 3.365 Catalina 10.15.4

I've mapped cursor keys to send 5,6,7 and 8 to the ZXSP (Sinclair machines emulator zx81, zx Spectrum etc) application.

I can see BTT is sending the keys to the ZXSP app but they are "ignored", if I press a cursor key several times very fast then the ZXSP app reacts correctly. I though it was a problem with the ZXSP app but then I tried with Karabiner and it worked fine.

I would like to only use BTT because I can bind the shortcuts to this specific app.

Thank you !

mapping cursor keys|439x500

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):