Lost presets when upgrading to 2.807 on lifetime license

#1

I upgraded last week to 2.807 (lifetime license) and lost all my presets. I've tried to recover from previous presets to no avail. Does anyone have any experience fixing something like this? I'm at a loss...

0 Likes

#2

In the latest alpha (v2.808) I added a menu item that allows to automatically restore from one of the auto-backups:

However it will only be shown if you open the "New Preferences Experimental Preview"
image

For restoring you should choose one of the backups from a version lower than 2.807

0 Likes

#3

Thanks for the reply. Where would I download this version? Is there another way to import these while not having to upgrade to alpha?

0 Likes

#4

You can use the "check for alpha version updates" in the menubar menu.

There are ways to rename some files manually, but I'd not recommend to do it. The alpha only contains some fixes that will be released as stable in a few days anyway, so updating should not be a problem.

0 Likes

#5

Sorry, it's not working for me. I've updated to the alpha version, and walked through the steps you outlined above. Upon restart of the app, none of the keyboard settings are applied and it's still not working. What else should I try?

0 Likes

#6

Which backup did you choose? Basically the last modified one before v2.807 should be working.

0 Likes

#7

I tried a few different ones, anything newer than 2019.

0 Likes

#8

Weird could you send the contents of this folder ~/Library/Application Support/BetterTouchTool (or at least the 2019 files) to andreas@folivora.ai? To open the folder use Finder => Go => Go To Folder and include the ~)

It looks a bit strange. Seems like you have been using v2.763 in April but then downgraded to an older version again.

0 Likes

#9

Should I try uninstalling and reinstalling the app altogether?

0 Likes

#10

I probably accidentally downgraded. I moved jobs and got a new license. I’m not sure what I did to screw things up!

0 Likes

#11

I'm currently checking the files, but something seems to be very weird. None of the backups seem to work, but I'm not yet sure why that is.

Do you maybe have a time machine backup of the ~/Library/Application Support/BetterTouchTool folder?
What kind of triggers did you have set up?

0 Likes

#12

I did find a few keyboard shortcuts, but they are from a relatively old file.

See attached presetexported_preset.bttpreset (35.4 KB)

0 Likes

#13

That worked! I think the process of changing computers, pulling from a backup and upgrading to the new license screwed something up along the way. Thanks for taking all the time to dig into this. Huge help!

0 Likes

#14

Moved to #discussion as there's not much to do with presets here!

0 Likes