lost config on latest version on Catalina

I'm on Catalina on version 3.540 and have lost some, but not all of my configs. The lost configurations appear to be application specific configurations.
I tried restoring from a prior backup and no luck - still gone. Is the issue that I'm not on Big Sur?
Is there some way to take a backup? Am I mistaken in assuming that my triggers are saved when I hit the save button within the trigger configuration? Do I need to cmd-S for every change?

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Just to make sure: are you looking at the correct section? (E.g. Trackpad)
It's pretty weird that only parts of the configuration got lost. Or do you maybe have multiple presets and one got disabled?

You don't need to press cmd+s.

I only have the one default preset.

I have also lost my config - I had configured only the trackpad.I have checked and I am looking at the correct section and I only have the default preset.
macOS version: 10.15.7 (19H114)
Type of Mac: MacBook Pro (16-inch, 2019)
BetterTouchTool Version: 3.553(1693)

In case a settings file got corrupted you can always try "Help => Restore Settings from Backup" which will let you restore from any of the auto-backups created.