Logitech mouse shortcuts not working

Under the "Normal Mouse" tab in BTT, I set some shortcuts based on my Logitech G403 Hero mouse, and they are not working.

They DID work for a few days but they randomly stopped working. I'm not sure why. I have the logitech g-hub software set with all default settings and nothing overriding BTT, still broken. I even tried fulling uninstalling logitech g-hub and restarting but it still did not fix.

SOME of the shortcuts work (side buttons used for fwd/back page), but the broken ones are custom scroll-wheel events (holding CMD or Option while scrolling up or down). Any idea how to get these fixed? I'm at wits end :frowning:

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):