Keyboard shortcuts prompting dropdown box instead of triggering action

Describe the bug
A clear and concise description of what the bug is.

When using the Fn + "KEY" shortcuts, if multiple applications have the same shortcut - instead of automatically triggering it, a box will come up giving me an option to click on the various shortcuts associated with the keyboard trigger.

The strange thing is that I have set these shortcuts under specific apps. For example, "Fn + S" triggers "Strikeout Text" in PDF Expert while it triggers "Opens Sidebar" in Onenote. When in Onenote, Fn+S will now give me this weird box to click on the options.

This issue is strangely new - was fine before.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Pro 2017

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)
image
image

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version:

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Which version of BTT are you using? (this could be an issue in the current alpha)

2.647 - latest alpha.

I get the same bug for all window-actioned keyboard triggers in the latest alpha, just not for keyboard shortcuts that have Touch Bar actions assigned.

Yup - reverting back to 2.645 solves the problem(s).

Will be fixed with the next alpha later today!

I think it should now work again in v2.648 alpha

Hey, I'm experiencing this exact issue here. I've just bought the lifetime license as I assumed it was due to my BTT being not the current version, but it's still happening after the update. Worked perfectly fine until a few weeks ago, and i'm really not sure what to do now. It's been super annoying to have the tool tip pop up everytime I hit a shortcut. :confused:

My BTT is on V3.402.

This happens if you have either:
• defined a shortcut multiple times in BTT
OR:
• are using FN based shortcuts and some other application has enabled macOS "secure input mode" (BTT will show a warning about that if you click the BTT menubar icon)