keyboard shortcuts not working in first try in webpage password field

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug

  1. Add new config in "Keyboard Shortcuts"
  2. Set the trigger as "OPTION+P" with "Insert Text by Pasting"
  3. Using Chrome/Safari/Firefox/Brave to open a webpage with password field, e.g.
  4. Click the "Password" field and press hold OPTION key then press P
  5. Observed only 1 character is input in the Password field
  6. Delete that character from the Password field, retry the key combination in step 4
  7. Observed proper value is populated in the Password field
  8. This problem was there for months and until today got a chance to submit the bug.
  9. Same problem when set the key combination to "Insert Text by Typing"

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Both Internal and wireless Apple keyboard

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 2016
  • macOS version: 10.15.7
  • BetterTouchTool version: 3.505(1643)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

  • Browser: Chrome 87.0.4280.67 (Official Build) (x86_64)
    Safari 14.0.1 (15610., 15610)
    Firefox 83.0 (64-bit)
    Brave 1.17.73 Chromium: 87.0.4280.67 (Official Build) (x86_64)
  • Workaround: use key combination 2 or more times