Keyboard shortcut has stopped working (Secure Input Handling)

Describe the bug
A few days ago, I started noticing that my (global) keyboard shortcut had stopped working. I first started noticing that BetterTouchTool would not be running at that time - which probably makes it rather obvious that the keyboard shortcuts were no longer working. When starting BetterTouchTool thereafter however, the keyboard shortcuts would still not be working.

Steps taken to troubleshoot:

  • First tried a simple reboot, unfortunately without any luck
  • I've tried updating from 2.513 to the most recent build 2.530 but without any luck.
  • Tried rebooting again, no luck.
  • Then exported my license and settings, removed BetterTouchTool through AppCleaner including all configuration files etcetera and installed BetterTouchTool anew. Imported my previously exported settings, but still without any luck.
  • Rebooted after reinstalling BetterTouchTool, yet again without luck.
  • Removed all keyboard shortcuts and re-created them to exclude any configuration issues, no luck.

Then I started fiddling around with some settings and found out that when enabling "Always use old keyboard shortcut implementation", all my problems went away. I'm guessing this is either related to recent MacOS updates in combination with BetterTouchTool; or the option that might have been randomly disabled (I'm not sure if I had "Always use old keyboard shortcut implementation" on before) without me knowing.

According to the release notes, 2.513 states "Hopefully fixed an issue with keyboard shortcuts when switching between Secure Input mode and normal mode" but I'm likely still experiencing this in a clean install of 2.530.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard (Shortcuts)

Rather hard to capture.

Device information:

  • Type of Mac: MacBook Air 13" Mid 2013 1.3 GHz
  • macOS version: 10.13.5 (17F77)
  • BetterTouchTool version: 2.530

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I could not find any useful information within that I can paste here. I could upload any logging and/or BetterTouchTool logging but am reluctant to doing so - let me know if there is a safe place to send any debug information to without any other people being able to look in to it.

I am having this same problem with v 2.530 (865). Having "automatically switch to old keyboard implementation" turned on does not work. I have to select "always use old keyboard shortcut implementation" for my shortcuts to work.

Still true for 2.536