Keyboard Modifiers not working in Touchbar

Describe the bug
I have set up button for ctrl-f5 and it only sends f5 and disregards the ctrl modifier.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
touch bar


Device information:

  • Type of Mac: 2018 15"
  • macOS version: 10.14.2
  • BetterTouchTool version: 2.667

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Seems to work fine here. In which app are you testing?

I'm having the trouble in Microsoft Remote Desktop 10.2.4

Ah ok. Issues with Microsoft's Remote Desktop are known, currently there is no solution but it's on my todo list to look into it. I think older versions of Remote Desktop work.

Ah okay, thanks for the quick response!

I have confirmed that it works properly in Microsoft Remote Desktop 8.0.44.

1 Like

Hi Andreas... this problem with modifiers not going through many recent (and not all that recent) MS Remote Desktop versions has been reported quite a few times over quite a few years (the compatibility mode doesn't fix it). Could we possibly get you to pop the issue to the top of your list so that we can all get it out of the way?

If it doesn't work try this terminal command:
defaults write com.hegenberg.BetterTouchTool BTTMSRDPWorkaround YES

If it still doesn't work with this, I'd report the issue to Microsoft as the app doesn't seem to react correctly to programmatically created keyboard presses anymore.

Thanks Andreas, I'll give it a try. but before I do, can you confirm that this is restored to the original state by replacing YES with NO?

yes, just make sure to quit BTT before running the command.

Looks like it's a no go. Tried it with and without compatibility mode. created a touchbar button that sends cntl-a and only the a comes through. So, no change with workaround in place.

Ok, thanks for testing!
Unfortunately I don't know of another way to send the modifier keys (BTT is using the Apple recommended ways to do that), so probably only Microsoft will be able to solve this.

As far as I know the RoyalTSX remote desktop client works fine with apps like BTT, but unfortunately it's not free.

Maybe the Microsoft RDP will respond correctly to Apple Script, so you could try something like this:

tell application "Microsoft Remote Desktop"
	tell application "System Events"
		key code 0 using {shift down}
	end tell
end tell

Okay... thanks for trying on this again.