Key Sequences not working

None of the Key Sequences triggers are being recognized. One time in Notes a sequence was recognized but only once.

Trackpad triggers are working so I'm sure BTT is running.

BTT Version: 4.184
OSX: Ventura 13.5
Hardware: MBP 2021 14" with M1 Pro chip

Tried using both Paste Text and Type Text. Neither option works.

Same issue here, with identical HW/SW setup.

I have keyboard macros using FN keys: F1, F2, F3 stop working after a while, F4, F5, F6 continues to work, F7, F8 also stops working. Reboot is only fix I have found

key sequences only work if secure input mode is not active. BTT will earn you about secure input mode when you click the BTT menubar icon

That's not the issue. I verified BTT warns about secure input mode by going into settings and asking to change my login password. BTT reported secure input mode was active. I canceled out of the password change and the BTT warning disappeared. Still no response to any key sequences.

maybe post some more details / screenshots about your sequences, in general they work well - many people are using them. Could be some system setting or some misunderstanding

I'll paste the screens showing the key sequence definitions below. I tried using Key Sequences as a second user on my MBP to see if it might be an unusual user setting but could not get them to work for the second user either. I've reviewed the documentation and settings and don't see any problems either with my system or user settings.

Have you tried adjusting the allowed "pause"`

This can easily cause issues because it uses a default of just 0.3s, this works fine for typed words, but when doing modifier combinations the pause is often a bit longer

That solved it. I played around with "Max pause" and got reliable results once I increased it to .5.

Thank you very much.

1 Like