Interesting behaviour when setting up BTT triggers on another machine - Triggers not working unless re-copied, and old instances deleted

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
When setting up my custom BTT profile on a separate computer, my BTT keyboard commands pertaining to one specific setup (will detail below) require deleting and re-entering previous presets to work.

In more detail:
My workflow is as follows. I dock my MBP and utilize a MX Master 3 (MXM) and Logitech Options. In order to further customize my MXM, I have all of the buttons set to "Gesture" buttons within Options:


The Options Gesture buttons are then mapped to a combination of keyboard keys which allow me to map them to BTT in order to create custom gestures for all of them. See below:

I will then, for example, map the keyboard shortcut "Cmd+Opt+Ctrl+6" to "Center Window" in BTT to allow me to quickly centre the active window on my screen:

I do this setup for every single button on the MXM and map them to different commands that work for my workflow, ie.

This setup has worked well for me to achieve maximal capabilities of my MXM while using it on my desktop. I'm able to achieve a lot of workflow optimization shortcuts (ie. window management, opening/closing tabs, moving windows between monitors) with simply holding a button and swiping in one of the four directions.

**My issue -> **
When replicating this setup on other devices, I run into an issue where all of the aforementioned triggers will NOT work on initial preset importing. This infuriated me in the past. To date, I still cannot figure out why it doesn't work on initial preset import.
The only way I have been able to fix it is to Copy all of the triggers, paste then back into the BTT config, and delete the old ones. This leads me to believe that there is some underling link per BTT instance that doesn't get carried over in the presets which pertains to this type of setup specifically.

All being told I can fix this by cutting and pasting all of the triggers as mentioned, and deleting the original ones in the preset, but it makes me wonder why this is an issue in the first place.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook laptops, Mini (all on OS Monterey, but issue has been persisting since Big Sur) in combination with Logitech Options + MX Master 3 mouse.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here) - added above.

Device information:

  • Type of Mac:
  • macOS version: Monterey 12.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.691 (1826)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):