Installed new version, all settings lost

Describe the bug
Yesterday I upgraded my license and upgraded from an unsupported version of BTT to a supported version. I'm not sure exactly which version I was on, but it will be whatever I had installed when the license changed. The version I upgraded to is version 2.660 (968).

When I opened the updated version, all my app keybinds and touchbar buttons were gone.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro touchar.

Device information:

  • Type of Mac: MacBook Pro (15-inch, 2017)
  • macOS version: 10.14.2 (18C54)
  • BetterTouchTool version: 2.660 (968)

There are backups of the old version in ~/Library/Application Support/BetterTouchTool/ (you can open that folder using Finder => Go => Go To Folder => then copy the exact path including the ~)

Make sure to quit BTT, then you can try to delete the newest files (should contain version_2_660...). Afterwards BTT will try to import the old ones again.

Thanks. I actually took the opportunity to redo all my buttons making them prettier and more functional, so I don't need to restore from backups, but it's great to know they're there. I just wanted to let you know it happened. Thanks for the response!

Unfortunately my settings all vanished again when I upgraded to the version released in the last couple of days. I have not been able to successfully restore them. Is there a more detail guide about restoring from backed up settings? Any idea why it keeps happening? I can't be restoring from backups every time there's an update.

Maybe there is some sort of file permission error on your system that prevents BTT from writing to it’s data files correctly.

Can you post a screenshot of the files in the ~/Library/Application Support/BetterTouchTool folder? Then I can tell you which to rename to recover.

In general maybe it will make sense to delete that folder, so BTT can recreate it with the correct permissions.

Here's my folder. This was a new installation of Mojave (not an upgrade) done a few days before the first update and wipe occurred.

My main aim now is to get my settings back. I didn't mind recreating them last time but I really don't fancy doing that again.


could you please include the modified date column in the screenshot?

I would try to:

0.) Quit BTT.
1.) Create a backup of that folder
2.) delete all three files that start with btt_data_store.version_2_686_build_0991
3.) rename the three files that start with btt_data_store.version2.660_build_0968 by replacing that with btt_data_store.version_2_686_build_0991

e.g. rename version2.660_build_0968-shm to btt_data_store.version_2_686_build_0991-shm

4.) start BTT and check whether it worked

It seems like you used an old version inbetween, maybe this was the problem? If possible make sure to only have one version of BTT running on your system.

1 Like

That worked, thanks. I didn't run another version in between, but it's possible I brought old settings from the old system, I don't remember if I copied them over. So I had an older version installed, wiped my system, installed the same version on the new system, copied over the settings (presumably), used it for a bit, updated to a new version (at this point all settings were lost), then updated to a new version (all settings were lost). At no point did the installed version go back a version, only forwards.

Hello Andreas,

This is happening to me now with every upgrade; settings are lost. Is there a fix for this?

most likely this is caused by file permission errors on your system, I’d try to follow these instructions:

Could it be a versioning issue; as for some reason I see that files are being modified from version 3_389 and 2_716 on the filesystem. See screen shot.

mhh maybe you have an old version of BTT somewhere? This could happen if the system sometimes starts a „wrong“ old version.

Maybe in your downloads folder?

Thanks Andreas, I believe this could have been the issue. I had created an autostart sub-folder in applications a while back and I believe during an update BTT installed itself back in Applications. Therefore there were 2 copies.

I'll try your instructions above to copy the old version as this worked before.
Thanks again for the amazingly fast responses!!! :slight_smile: