Importing Presets Is Now Broken

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

If you import a preset on a version after 3.531-1670, almost all triggers will lose their actions (usually happens with those having keyboard shortcuts). This doesn't happen on 3.530-1669 or earlier, but also happens with 3.532-1671, meaning that 3.531-1670 broke the importing process.

Multiple users on AquaTouch's Discord server had this problem. By trying each version and importing AquaTouch and our own presets, we were able to determine that 3.531-1670 introduced this bug.

This only affects importing because, once imported, presets still work perfectly with the latest BTT version.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Noticed on Touch Bar triggers, but could also happen on other input devices configurations (not tested)

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBookPro16,2
  • macOS version: macOS 11.1 (20C69)
  • BetterTouchTool version: (please post the exact version - not just "the latest one") Starting from 3.531-1670, including 3.532-1671 which is the latest as of writing

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Workaround found:

  1. Install BTT 3.531-1670
  2. Import all presets
  3. Update to the latest version

I was also having the issue. This solution worked for me as well.

Thanks for reporting! I'm currently building v3.533 alpha which should fix this, should be available in a few minutes

Imprint | Privacy Policy