If text is entered in ANY field, 2 finger gestures stop working, and instead moves the cursor.

Describe the bug

Mojave, Safari, also Firefox.

I have 2 finger gestures turned off in System Prefs
I have 2 finger gestures mapped to the hotkeys in Safari and Firefox, this allows me to execute the forward and back gestures without reload.

However, if the cursor is in a text field, ANY text field in either Safari or Firefox, instead of going forwards or backwards, it will only move the input cursor. This behavior is new, it didn't used to do this.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Movaje, Trackpad, BTT 3.0 + only

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2019 MBP 13" TB
  • macOS version: Mojave
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.209, works fine with 2.0 stable
    Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Let me update, I tried to reinstall again BTT 2.0 and it crashes immediately with this log

Process: BetterTouchTool [597]
Path: /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool
Identifier: com.hegenberg.BetterTouchTool
Version: 2.05 (605)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: BetterTouchTool [597]
User ID: 501

Date/Time: 2019-12-03 21:01:27.118 -0700
OS Version: Mac OS X 10.14.6 (18G1012)
Report Version: 12
Bridge OS Version: 4.1 (17P1081)
Anonymous UUID: A029DA07-2054-3FA3-9937-4B596B12C6F5

Time Awake Since Boot: 190 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '+[NSTouchBar minimizeSystemModalFunctionBar:]: unrecognized selector sent to class 0x7fff92c3afd0'
terminating with uncaught exception of type NSException
abort() called

Imprint | Privacy Policy