HUD text entry is ghosted and text cannot be entered for new Triggers

Describe the bug

For new trigger items (I've tried keyboard and drawings), the HUD text entry is greyed out and I cannot enter any text:

A bit hard to see but can you notice HUD title and HUD detail text is a bit greyer than Notes text entry? This means those text fields cannot be clicked on to enter text.

Exiting Triggers have those fields un-ghosted and existing text can be modified...

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Keyboard and mouse drawings tested.

Device information:

  • Type of Mac: macbook pro
  • macOS version: 12.5
  • BetterTouchTool version:3.821

you first need to check the checkbox, then they will be enabled

I had tried that but they are still inaccesible:

Screenshot 2022-07-28 at 19.18.10

And note for older triggers I can still edit the text even when the checkbox is disabled:

Screenshot 2022-07-28 at 19.26.01

You are right, I introduced a bug in my form builder code with the last update :frowning: Thanks a lot for reporting, this affects various other things as well!

I think it should be fixed with the new alpha version (3.822, will be online in 10 minutes)

// edit: sorry 3.822 didn't fully fix it, 3.823 should do the trick

1 Like

Confirmed working again, thanks for the fast fix Andreas!