How to resolve the conflict of key sequence in AltTab shortcut


I hit a problem about the conflict of key sequence in AltTab shortcut, tried many ways, but no solution.

I have below key sequence.

And I installed AltTab to switch window.
but when I using cmd+tab+shift to switch to previous window, it will trigger the shift key sequence in btt.
I have tried to disable btt in AltTab, but not worked, seems AltTab is working in the background.

May I know if any solution to resolve this?

Have you tried this?

Double tap shift (instead of just shift).

Thanks to your suggestion. But I don't want to double shift, because I use shift to switch keyboard input source very frequently. Don't want to tap twice.

Ok, then maybe like this. If you reduce the time between two keystrokes to a minimum, your "shift-sequence" should only work if down/up is (very) fast.

when I is holding cmd and click shift is also very fast to switch window. When I am inputting something, and click "shift sequence" is very fast too.
So I am thinking maybe if there is an option to disable the sequence when holding cmd down, that would resolve this problem.