how to disable maximizing?

Hi, pls excuse newbie Q but I can't find this in the Prefs- whenever I move a window to the top R corner it maximizes and U don;t want this - how can I disable it please?

Thanks v much
RR

you can configure this in the settings: