How can I disable snap to screen?

I am finding Snap to Screen is becoming a nuisance. How can I disable this feature?

In the settings:

Got it! Thanks