High CPU of BTT and TouchBarServer process when displaying the configuration or a floating WebView.

Since a few days (maybe since the update to Big Sur 11.5?) I have massive problems when displaying any BTT window (configuration, or floating WebView). The processes:


run on 100% CPU. Partially BTT freezes.

I have (clear) reinstalled BTT completely, restored the presets from backup, etc. After that it works for a while. If the problem occurs, it only helps to restart BTT. There is nothing to see in the log.


Any idea?


Device information:

  • Type of Mac: MacBook Pro 16' (2019)
  • macOS version: Big Sur 11.5
  • BetterTouchTool version: 3.570 (1710)

can you take a sample of the process using this terminal command and send the result to me? (andreas@folivora.ai)

sample BetterTouchTool -file ~/Desktop/sample.txt


Additional infos for @Andreas_Hegenberg:

If the problem occurs (e.g. if I want to display the BTT configuration), then an X appears in the Touch Bar on the left (otherwise not):

It seems as if BTT wants to display a Touch Bar, although according to the settings it should not be the case, as I have only made app-specific settings and BTT is the active app.



Unfortunately I haven't been able to reproduce the issue yet, but this might lead me to the right direction.

Your first sample didn't contain anything unusual, which is quite weird. It might have been a "unlucky" sample, so if you run into this again, it would be great if you could send one or two more samples.

// edit: nevermind, I just saw you already send another sample!

Hi @Andreas_Hegenberg,
I'm also having the high CPU issue. I've discovered that it is with the preset I built myself. But I don't know what is the cause of it. I tried:

  1. fresh reinstallation of BTT and reimport the preset.
  2. create a new preset and copy the triggers/actions from the old one.

The 1st does not solve the problem.
The 2nd, when I copy triggers/actions for a few apps, it seems to be fine, but as I copy more, CPU usage starts to climbing up...

Not sure if it is related, I have AquaTouch. I created some of my own after AquaTouch, and these newly created are saved to the old default preset.

What's odd now is this:
Before, when I deactivate AquaTouch and use only the old default preset, the apps and the custom groups where I had triggers/actions will show up in the left column of BTT editor.
Now, after I copy triggers/actions over from the old preset to the newly created preset, if I deactivate the old preset, BTT shows nothing in the left column. When I add the apps to it, all triggers/actions will show up. In other words, I have to readding all the apps and creating groups from here:

Another thing I just noticed today:
After I copy a few sets of triggers/actions from the old preset to the newly created one, BTT starts to demanding higher CPU, like 65%. This happens even the old preset has been deactivated. However, when I activate AquaTouch, CPU usage immediately drops to normal level. Apparently something is going on here.

Maybe you already have an idea about what's going on. I'd also be happy to send you the presets for debugging.


I have just uploaded a first alpha that tackles the macOS 11.5.x freezes: http://folivora.ai/releases/btt3.572-1716.zip

Unfortunately the issue is deep within macOS, so I needed to create a pretty complex workaround. It already works pretty good in my tests, but there might still be some issues which I'll fix in the coming days.

Thank you Andreas!

That solves the problem with the CPU and the configuration is usable again.

Greetings Dirk

I had what seemed to be related issues whenever I opened the clipboard history dialog. With this alpha version, that issue is fixed. Thank you!

macOS 11.5.1

I spoke too soon. Freezes happen every time I open the clipboard history dialog.

macOS 11.5.1
BetterTouchTool 3.572 (1716)

I'm also running Karabiner-Elements.

It looks like my issue may be different than this one. I'll create a separate report.

I just downloaded the latest alpha because I was experiencing extreme (unusable) UI slow downs when using the configuration tool to create new Touch Bar buttons with actions etc.
So far this seems to have solved the slow downs I was experiencing.
I'm on an M1 Mac.