Hide BTT touchbar

touch-bar

#1

Describe the bug
Show BTT after waking from sleep option is disabled, however the BTT touchbar appears always after sleep.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touchbar

Device information:

  • Type of Mac: MacBook Pro 15" 2018 with touchbar
  • macOS version: Mojave 10.14.1
  • BetterTouchTool version: 2.660

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I just want to have the BTT button on the control strip, and open all the configured actions manually.
Don't want the BTT buttons to appear automatically never.
Is there any way to achieve this? All the BTT touchbar options are a bit confusing.

Also it will be nice to be able to setup an action to close the BTT group after triggered.
For example, configure a Sleep button to sleep the computer, but after waking, restore the normal system touchbar and don't show the BTT group. Or any other "one time" action, without the need to explicitly close the BTT group.

Thanks


#2

Came here to post about this. I also experience this on a 2017 macbook pro running high sierra 10.13.6, BTT 2.660


#3

Same thing happening to me too sadly after updating BTT to the latest version :frowning_face:
I too have a 2017 macbook pro running high sierra 10.13.6
My solution for now is to go back to version 2.645 which isn't quite so over enthusiastic to help and stays hidden until called for.:slightly_smiling_face:


#4

Same issue here. I really hope there is a fix soon


#5

I think alpha 2.681 fixes this issue. Can you test this as well?


#6

Thanks for reporting! should be fixed in v2.682 which is now available.


#7

Hello Andreas,
Thank’s for trying to fix this in the latest update (v2.682) but now BTT pretty much won’t come out to play at all for me!

If I Sleep or Restart my Mac the strip shows my customisations first not the OS/App defaults. If I then dismiss these to get the OS/App defaults back, I can not afterwards bring up any of my custom strips. I can tap BTT’s icon in the Touch Bar as much as I want but nothing happens.


#8

Exactly the same. BTT shows up after waking from Sleep and no action if I press the BTT button on the control strip. Thanks for trying to solve this. :smile:


#9

I can't reproduce this behavior here, but made some changes in v2.683, maybe they will help in your case!


#10

Hi!!
Almost!, the BTT bar doesn't show up after Sleep (great!), however the BTT button in the Control strip is still unresponsive, no matter what app is currently active.
If you want I can send you some screenshots of my current config.


#11

If possible please go to the about tab in BTT and press the "Export debug information" button. This will create a folder BetterTouchToolDebug (with your exact setup) on your desktop. If you send that to me I should be able to reproduce it.


#12

Sorry, But it started to behave incorrectly again after wake up, I don't know, maybe the system didn't sleep completely when I first tried this. I uploaded my config,

BetterTouchToolDebug.zip (59.2 KB)


#13

Me again,
v2.683 is almost totally unresponsive.
Waking from Sleep or Restart, BTT is hidden with just it’s icon showing in the Touch Bar but no amount of tapping it will rouse it into action.
However if I restart BTT, my Global strip comes up and I can hide it by tapping the BTT icon. But after that BTT refuses to respond again.
I attach debug report here.v2.683BetterTouchToolDebug_User_markw.zip (786.5 KB)


#14

Yes, I am having the same issue as Markw. if I press the BTT button to make it go to sleep I cannot wake it up any more. I have to restart the BTT in order for it to work again. It was doing it in version 2.682 and now in 2.683 as well. Hope there is a fix soon.


#15

I hope I have identified the issue and fixed it in 2.684, would be great if you could test. (It was hard to reproduce because it doesn't happen in the debug version, only in the release version of the app :frowning: )


#16

Good morning Andreas,
And it is a good morning :grinning: v2.684 is behaving impeccably so far,
this is more like the BTT we know and love :sunglasses:
Thanks for all your hard work fixing this issue and in the holiday season too!
Best wishes for the coming new year :fireworks:


#17

Well it partially works.
I had to explicitly close and open BTT to start working, but I see two problems:
If you close BTT bar using the "x" button, then you need to press the BTT button two times to open the bar again.
Also, If you close the bar using the "x" button, and use Sleep or Reboot from Apple menu or from a key combination defined in BTT, then the BTT bar opens automatically on start.
Also, If you define a Lock or Sleep button in the BTT bar and use it, then on Login or Wake the BTT bar opens automatically, this may be theoretically correct as it was already open, but this relates to the option I write in my first post, that it would be good to have, to automatically close the BTT after an action is executed, so in that case, the BTT stays closed on return.
Thank you for the work and dedication!!
Have a good end of year!!


#18

that's normal, the x button is not part of BTT, but is added by the system, and unfortunately BTT can not know when it has been pressed.

You always need to press the control strip icon to show/hide.

If you hide the control strip in BTT's touchbar settings, the x button will not be added by the system.

You can attach an additional predefined action "toggle BetterTouchTool Touchbar" to achieve the lock behavior.


#19

Ok, you alternatives are a good option.
The only thing is it would be nice to have an autoclose BTT bar option after an action trigger.
Thanks for you time!!
Good year!


#20

This info was super important for me! I didn't know that BTT can't recognise the system wide "x" button in the touchbar. Always used that one to hide the touch bar - no wonder it always reappeared after sleep :wink:
I have disabled the control strip now to help me not use the x button from the system when the touchbar is in use. Now I only need to find a neat replica of the system control strip that I could add so that it looks consistent.