GoldenChaos-BTT Support and Feedback Thread

Agreed :frowning: I really have no idea what's going on.

For what it's worth, when I tried the "fresh" re-install, even having deleted the previous preset GC tried to apply the previous settings and to some degree, it worked. Is there a way to fully erase all memory of GC and re-install? Maybe this will fix whatever is going on with my machine.

In any case, can you elaborate a bit on which screenshots you're looking for? Happy to provide whatever you need.

EDIT - downgraded back to 3.186 and now the CTRL modifier menu is working just fine again.... V strange.

@GoldenChaos for me, pinyin-simplified is not working properly, as the globe doesn't show up. Also, it seems that the dark mode icon is working perfectly now. Thanks for responding!

I've noticed that my machine slows to a crawl when I'm copying cell data in Excel 2016, particularly when I'm in spreadsheets with large numbers of cells. It doesn't matter how many cells I select (it can just be a single cell), only that there are many in the whole spreadsheet. The memory usage of BTT seems to jumps up when I begin to copy data and the Touch Bar seems to freeze, typically showing the GC options when the command key is pressed. If I quit BTT or shut off GC, I do not seem to have any problems at all. This also doesn't seem to be a problem in Excel 2011 from what I can tell. I'm running BTT 3.195 and GC 3.194. I believe it was still a problem when I was on the previous BTT/GC versions I was on, I think 3.187.

Excel and other Microsoft apps unfortunately use very weird clipboard management (different from any other app on the Mac), which is why BTT's clipboard manager might not work well with it.

In general the Touch Bar widget uses the same settings as BTT's main clipboard manager - which means that it should have the microsoft office optimizations enabled. However I have never tested them with the old Office 2016

You can however disable the clipboard manager for Office apps if you want to:

This is a screenshot of the main clipboard manager settings (predefined action show clipboard/pasteboard history)

BetterTouchTool 3.200 is out! GC-BTT 3.200 Stable is on the way and will be out shortly. I'm preparing the release now :slight_smile: once it's out I'll update all the screenshots and documentation. It includes some minor bug fixes for RC2, plus an extra menu bar widget I snuck in, but otherwise RC2 totally passed muster and now I just need to write the giant release notes.

1 Like

Hello I've having a small issue. I have both Clipboard History and Emoji Picker enabled in my menu bar. When I tap the clipboard history button, it switches places with the emoji picker button. When I push Clipboard history again and it goes away, and the order reverts.

1 Like

Whoops, looks like they're set to the same display order number - I'll push out a bug fix update to the stable version tomorrow that fixes this :slight_smile:

1 Like

Always when you think you're done!



Golden Chaos randomly stopped working for me today. I was thinking that i may have to reinstall it so i did the latest version and still nothing. It's like it doesn't recognize the application.

Could you share some more info? GC version, BTT version, macOS version, screenshots of your Touch Bar and BTT config window, etc?

it seemed to have fixed itself, thanks.

1 Like

Would it be possible to support brave browser?
Thanks so much for this awesome preset!

I can definitely look into it! As long as it supports scripting, it should be possible :slight_smile:

could you also make the tabs feature of GC-BTT preset to support Opera and Vivaldi? That would be great thanks!


I have 24-hours time format, in the system settings and GC-BTT I've set the 24h format, but my events from Fantastical shows in am\pm format.

maybe you have a region override in g the he BTT settings?

It works, thanks! Too many places where I have to do it (system, GC-BTT, BTT)

Everything is working pretty great in the latest stable release, but I've noticed the Deliveries app never shows up on my touchbar when there's a dock badge for the app and it is obviously enabled in settings. Curious if there's something more to do to get it working?

Huh, the Deliveries badge is mysteriously missing from the stable build? Welp, time to push out an update, haha. I'll have this fixed by tomorrow.

To be fair, I'm not sure I've ever seen it work on any of the beta builds. :flushed:

Imprint | Privacy Policy