going bananas with drawings: can't redo and do not trigger assigned action.

BTT 3.756 Catalina 10.15.7
I have been using BTT for years without problems. I recently tried to also use drawings.
I read all the help I could find on drawings on your web site.
I can generate drawings, assign actions etc no problem.
I have 2 problems:

  • I can't redo drawings. When I reset and redraw, nothing happens.
  • none of my drawings trigger the assigned action although I was careful to following the instructions on how to best create drawings.
    thanks in advance for your time and help

Could be a compatibility problem with macOS 10.15.x I haven't worked on that for a while.
I'll try to reproduce your issue in a virtual machine.

1 Like

thank you.

Before I make a drawing on my trackpad to trigger an action, do I have to tap a gesture or type a keyboard shortcut to tell BTT and my trackpad that a gesture is coming, or do I have to press a modifier key during the drawing ?

By default drawings start when you two finger click the trackpad and stop as soon as you release the click. However other triggers can be used as well by assigning the "Start Recording Drawing" and "Stop Recording Drawing" actions

1 Like

thank you. I tried adding those actions and it does not help

What happens on two finger click & drag?

I'm sorry: I don't understand. What is the drag part of click and drag ?
2 finger click bring up the context menu

instead of releasing the click, you keep the trackpad pressed and move around with one or two fingers

OK. thank you.
Nothing happens with 2 finger click and drag

Is this enabled? (Should be by default)
And you have some drawings defined, correct?

Yes

thank you

Finally, I found that if I deleted the drawings and re-create them it works, except for the fact that I cannot redo a drawing.

If I click on reset current drawing, nothing happens. If I redraw the drawing it does not replace the old one.