Global keyboard triggers no longer overridable by app-specific action to "Use Apple Default or Do Nothing" with old keyboard shortcut implementation

Describe the bug

  • "Always use old keyboard shortcut implementation" checked in advanced Keyboard Settings
  • Global keyboard trigger: Ctrl-C, action: Cmd-C
  • Terminal app-specific keyboard trigger: Ctrl-C, action: Use Apple Default or Do Nothing

Expected behavior:

  • Ctrl-C triggers Cmd-C in all applications except for Terminal, in which Ctrl-C just sends Ctrl-C. This worked before, in a long ago version.

Actual behavior:

  • Ctrl-C triggers Cmd-C in all applications except for Terminal, in which Ctrl-C does nothing.

Additional comments:

  • The global trigger is overridden correctly, as if I change the app-specific action to show HUD, it works.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
All keyboard, internal and external (USB)

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro (15-inch, 2016)
  • macOS version: 10.13.1
  • BetterTouchTool version: I tried the alpha 2.694 and the latest stable

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Workaround is to disable BTT for the app, but then I can't use window snapping either. It would be nice to have an option to just disable keyboard triggers for the app.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

This seems to be working fine here.

Could you go to the about tab in BTT and click the "Export debug information" button? This will create a folder called BetterTouchToolDebug. If you send that to I will be able to see and test your setup here.

Could you confirm it is working when you disable the "old shortcut mode"? If so I'll check why it's not working correctly when that mode is active.

I think I have identified the issue, would be great if you'd try v2.695 alpha.

Yes! It works when "Always use old keyboard shortcut implementation" is unchecked. Now I don't remember why I checked that in the first place...

Ok, I will check the new alpha.

Now it works with the old keyboard shortcut setting checked and unchecked in the latest 2.695 alpha.

Thanks a lot.

1 Like