"Frozen" keyboard shortcuts

Describe the bug
Sometimes, BTT "prevents" some keyboard shortcuts from being executed in an application. For instance, I do not have any keyboard shortcut linked to CMD-R, but a couple minutes ago this shortcut stopped working in Safari (e.g. to refresh the page). Restarting BTT immediately solved the problem. This does seem to appear randomly without any cause (or I can't notice it), regardless of the application - and restarting BTT always solves the problem (I haven't found any other solution).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac: MacBook Pro (Retina, 13-inch, Early 2015)
  • macOS version: 10.14.5 (18F132)
  • BetterTouchTool version: 3.101 (1208)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):


This is still not resolved. Did you have time to look at it?


I have not heard of such an issue before and no similar reports yet. In general BTT only listens to stuff configured in it.

Do you maybe have cmd+fn+r configured somewhere? If macOS enables secure input for some reason, FN keys can not be accessed anymore

pressing cmd+fn+r in Safari leads to a reloading of the page, as expected I assume - so no, nothing is bound to that shortcut

actually, the only times I noticed that is in Safari, with cmd+r (reload) and cmd+t (new tab) - just took a look at my btt shortcuts and nothing should be interfering with that

any troubleshooting steps/logfiles to investigate further? this is still an annoying behavior from btt