Forced to update, now BTT gestures are completely non-functional

Running latest version of Monterey. BTT forced me to upgrade and immediately upon install of the new version all custom gestures stopped functioning.

Better yet, when I click to Restart BTT from the menu it gives me a "Could Not Restart" error that says if I open BTTRelaunch it should fix it. Oops, clicking that doesn't fix it and Restarting BTT always shows the same "Could Not Restart" error.

Why do you need to force me to update? I previously stayed on a single version of BTT for years because I had no reason to update. Let us use the app versions that are WORKING for us so we don't have to deal with bugs and be your beta testers for new versions. I genuinely do not have time to deal with this.

there are no forced updates. What did BTT do to force you to update?

Thanks for the quick reply. First a popup showed up that said something about this version of BTT no longer being supported. The version I was running prior to the update was downloaded from the BTT website about 14 days ago with a fresh Monterey install, so I wasn't running a years old version like I mentioned I had in the past. After the notification all my gestures were deactivated and there was a red warning in the drop down menu saying "BetterTouchTool has been disabled."

Reluctantly, I used the option in the drop down to download and install the new update. Now no gestures work even though they are all still listed and I get the "Could Not Restart" error. Already tried restarting the MacBook and other basic troubleshooting.

Could you send your license info to sounds like the license might have gotten deactivated for some reason.

It's not the license. All the issues happen whether I have my license installed or I remove it and revert to a trial version. After wiping everything and doing a clean install now I just get the error "Could not merge changes" over and over. This latest version of BTT is simply non-functional and, as I dreaded finally happening, apparently removes the old configuration UI.

How do I get back on the previous version?

if a license has been blocked the whole computer gets blocked, so a trial version would not work anymore either. If you forward me the details I can have a look and unblock if it was an error.


Your license is all fine, so no server side blocks or anything.

I don't think it's an issue with the version, but you can downgrade to any previous build via Index of /releases
Which was the version/build that caused the issues for you?

Sometimes in such cases a system restart can help for file permission errors (e.g. if BTT is not able to access the license information, or the macOS service that's used for license validation is in a weird state)

For new users the old legacy UI is disabled because it only contains a subset of the features and is buggy on newer macOS versions, but you can always reenable it using this terminal command:
defaults write com.hegenberg.BetterTouchTool BTTDisabledLegacyUI NO
However if it's not available this also indicates a file permission error because it means BTT wasn't able to read its preferences file.

Downgrading to a random previous version immediately restored gesture functionality. All other issues, such as "Could not restart BTT" or "Could not merge changes," are also gone. Even without restarting the machine.

3.609 1757 is the version I was forced onto that caused all the issues.

Very weird, 3.609 has already been installed on more than 10k computers so it doesn't seem to be a general problem. It sounds a bit like some code signature or Apple notarization issue, but then other machines should be affected as well....

Which macOS version are you currently running?

I have the same problem:
"Could not restart
There was an issue restarting BetterTouchTool. This can usually be fixed by opening the BTTRelaunch app manually once. BTT will now show the folder that contains the BTTRelaunch app."
MacOS Monterey 12.0.1
BetterTouchTool Version 2.636

You are on a very old BTT version, possibly there are incompatibilities with macOS Monterey using that version.

So, you force to update?

No, you can keep using the old version as long as you want, but it doesn't get updates anymore and is of course not tested with new macOS versions anymore. (It will forever work with older macOS versions)

I am now running into the same problem. I have tried uninstalling and then reinstalling BTT multiple times. Currently running version 3.732 of BTT and I have Monteray os.
I am enrolled in the Mac Beta program for new os, so that could be a problem but I've had both BTT and the beta enrollment since I bought BTT and no problems until recently.
All gestures have been disabled. When I try and use a preset from the community (I use AquaTouch) none of the gestures work, including the default of BTT.

Have you checked whether your BTT is maybe just disabled? Click the menubar icon, does it show "enable for ..." or "disable for..." ?

Do you have your license activated on that machine?

From everything that I am seeing it is enabled. When I click on the icon in the top corner of my desktop. Towards the bottom of the dropdown menu I see "Disable BTT for" and then it gives me the options to disable BTT for all apps or just the active apps.

As far as my license goes. I have only ever used it on this machine and I was pretty sure I activated it. However when I just reinstalled and went through the process it gives me the option to import a license for BTT. When I do that it accepts it but then immediately quits the application and gives me the error message, "Could not Restart."

Update: I reinstalled the newest os for my Mac and it seems to have solved the problem. I don't know if there is something that just got messed up with my Mac being enrolled in the beta os program. But after I reinstalled the latest os available to me the problem was completely fixed.

I figured it was more of a problem on my end rather than BTT as it is a phenomenal app that makes the Touch Bar useful. So thank you for your quick responses but I have solved my problem.

To anyone who may look at this in the future, if your Mac is enrolled in the beta program 1. make sure you have the newest os as they rolled updates for it constantly. 2. If you are on the latest try and reinstall the newest version of the os as that fixed my problem.