"Fn + Key" keyboard shortcut maximizes windows ... Details in thread + solution!

Describe the bug

An interesting bug. I'll try and describe it as best as I can - please ask for clarifications as necessary.

Has been tested on two different applications: PDF Expert (PDFE) and Microsoft Word. I'll describe my experience in PDF Expert:

  • Normal keyboard shortcut in PDFE to highlight text is "CONTROL+CMD+H". I wanted to make this an easier shortcut, so in BTT I designated "Fn+H" to trigger "CONTROL+CMD+H" in an App-Specific Trigger.
  • I normally have a Word document on the left half of the screen to take notes, and PDFE on the right half of the screen. When triggering "Fn+H" on PDFE, the window will maximize.
  • Ticking off "Compatibility mode for shortcut sending in PDF Expert" solves this problem. - i.e. after ticking this setting, triggering Fn+H will NO LONGER maximize the window.
  • This bug only occurs when "Fn+H" is set to trigger "CONTROL+CMD+H" or some other keyboard shortcut (i.e. same thing occurs if I set it to "Add Rectangle" which by default is "CONTROL+CMD+R". IF I USE A MENUBAR-ITEM TRIGGER i.e. "Menubar-Item: Annotate;Highlight", triggering Fn+H will NOT maximize the screen.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

In short - solution for this bug is to tick off Compatibility mode for shortcut sending (which is ironic as Fn keys shortcuts still work).