File not found error

Since installing the MacOS 12.3 beta last week, I have been getting many "File Not Found" Finder error dialogs. I reported to Apple thinking it was a beta issue. They asked me if I tried uninstalling BTT. I have not, but I do note that the errors have stopped since I installed the BTT update this morning (3.741). Is there a conflict between the previous stable version and MacOS 12.3?

MBP M1 13" (2020). MacOS 12.3

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

yep it was related to a change in the shortcuts app, it’s now fixed in the latest BTT :slight_smile:

Awesome! Thanks, Andreas!

Hello, I just changed my device for a newer (MacBook Air 2020 M1), which is running on newer IOS, and precisely the same error occurred to me. When I open the Mac, I sometimes have more than 20 windows "file not found" there. Is the only chance to fix it to buy a newer version of BTT? I purchased the license a few years ago, and I was satisfied with the old version of BTT because I use it only for my non-apple mouse, and I don't need any new special functions...
In case the only opportunity to fix the bug is to buy a newer version, I don't find it entirely fair because the reason for me upgrading wouldn't be my will to improve the functions but the bug of the app.

BTT updates always contain bugfixes and they are not available if your license doesn’t cover the versions anymore.

If you don’t want a new license you have two options:

  • use an older macOS version
  • use an older BTT version that doesn’t have Shortcuts support (Index of /releases)

Ok, that sounds reasonable; thanks for the advice.

I have a brand new MacBook Pro, and in migrating to it, I'm having this issue again.

I have BTT through SetApp and the version is current, so in theory, old licenses shouldn't be an issue?