File is corrupted?

When trying to download and install version 4.208-2428 several times, I get the error message "this file is corrupted, it is recommended ...".

How are you downloading? Via the integrated updater?

No, by hand ... old habit. :slightly_smiling_face:

Indeed, when downloading by hand it fails. I'll check what's wrong.

1 Like

can you try this one?

Everything back to normal.

Good :slight_smile: Stupid code signature issue.

If you had a previously set up "Find Image On Screen and move mouse" action, it would be very interesting to know whether it still works with this version (I completely replaced the algorithm with a much more sophisticated, OpenCV based algorithm)

Unfortunately or fortunately not :slightly_smiling_face: But I noticed that all move and click actions no longer work. And I mean really all of them, unfortunately.

So, mouse moves to a dropdown menu, clicks, menu opens, mouse moves to a menu item and clicks again (all related to a corner of the active window).

Have you changed anything there recently as well?

No, these haven't been touched at all in a long time :slight_smile:
Are you holding some modifier key that could affect them?

Ah well I mean clicks have not been changed. The mouse move action has gained a few new options, but they should not affect the old behavior

Maybe my problem has nothing to do with it. Or maybe it does. :slightly_smiling_face: I guess I will have to redo them all?

Wait a moment, I might have an idea...

Mh no, I just tried to set them up in an old version, then execute them in the current version. Still works fine here.

Don't they move the mouse at all in your case? Or to a wrong position?
Maybe you can send me the debug data, then I should be able to reproduce it :slight_smile:

The first mouse movement and the first left click are executed. Then nothing more. (Example above)

That would suggest, the delay action is causing the issue. "Unfortunately" that also seems to work fine here.

I set up the second mouse movement again (and did not change anything on the delay). It works again. The y-value has become negative. But I don't know if this has any meaning :slightly_smiling_face:

I changed the y value when saving with newer versions. I think it makes more sense like this.
However by re-recording the position, BTT now uses the new mouse move implementation. So something seems to have broken in the old one (which is also weird because your first one works).

Mhh gonna do some experiments.

Do you maybe remember when this last worked?

I have updated from 4.204 to 4.209. It worked with 4.204.

No, wait, I'm not quite sure. It might not have worked even with 4.204. I do not know anymore.

Anyway, I just change this second action. That's tolerable :slightly_smiling_face:

1 Like