export_preset script not working

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

  • I have upgraded to alpha, the problem persists.

Describe the bug
when I run the export_preset command, I get the following error:

519:620: execution error: BetterTouchTool got an error: "tigger" doesn’t understand the “export_preset” message. (-1708)

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Air M1 standard, no external peripherals

Device information:

  • Type of Mac: MacBook Air 2022 M1
  • macOS version: 12.6.6
  • BetterTouchTool version: 4.091 (2307)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
This had been working fine until I did a reformat of my system, imported my old preset, and now it won't export this one.

What command are you using exactly?

This seems to work fine here in the current alpha:

tell application "BetterTouchTool"
	
	export_preset "PresetName" outputPath "~/Documents/test.bttpreset" comment "someComment" link "https://someLinkToShowWhenImporting" with includeSettings and compress
	
end tell

Oh interesting, I just upgraded to the latest alpha, now it works again! :smile:

v4.100 (2316)