Execute Shell Script/Task

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
The Execute Shell Script/Task does not allow command arguments with embedded spaces. In the bash shell, for example, a command argument with embedded spaces can be specified by surrounding it with double or single quotes. It appears that this action always treats spaces as argument delimiters, regardless of if the space is within quotes

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac:MacBookPro14,3
  • macOS version: 10.15.7
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.553 (1693)
    Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

You can separate the parameters with


Then spaces will be allowed in the individual parameters. E.g.

-b;;com.apple.Safari;;https://google.com/ test /

I need to add this info to the UI.