Everything stopped working

I was a happy user of BTT for the longest time, but magically, quite possibly when Mac OS 10.15 dropped, it stopped working, and now displays the normal default toolbars for all apps that I'm in, rather than the cool minimalist toolbar I want.

Here are my settings: they should show the Esc key, the weather, and the notification center on the right. Everything else is toggled off, at least I believe it is. I am trying to keep one Global toolbar as I find toolbars that shift their content depending on different apps to be confusing.

Can any smart person tell me what I'm likely doing wrong? Using a brand new Macbook Pro 13 inch, but the issue happened on my previous computer (identical model). This has been incredibly frustrating because I can get the proper toolbar to work with BTT is active, but then Google Chrome, Safari, Finder etc. show their own toolbars regardless of what I'm trying to get BTT to do globally.

Thanks for any suggestions you can offer.

On Catalina make sure your Touch Bar configuration in System Preferences => Keyboard looks like this:

If it already does, maybe your BTT Touch Bar is just hidden. I'd recommend to set a keyboard shortcut in BTT and assign the predefined action "Toggle BetterTouchTool Touch Bar", then you'll always be able to hide/unhide it.

Thanks for your help. I also tried exporting my profile then deleting the prefs. That caused the app to report itself as "expired" do I downloaded a new copy and things started working better, so it's possible I had outdated software. I also checked the above panel.

Now the only problem is, how to get rid of the X in a circle that shows up sometimes at the left edge.

Disable this in the BTT Touch Bar settings:

Thanks, I checked that that was off. The "X" comes up when I'm using Chrome or Safari, but not the Finder. Clicking the X makes everything go away except for the Esc button until I click to a new app.

Here's a screenshot

Are you sure your system preferences look like in the screenshot above? Needs to be set to "App Controls"

Here's what that screen looks like. I do have "Show control strip" off because otherwise a bunch of control strip elements appear from the right side, making it look like below.

The only way I can get rid of the X in the white circle at left is to go to the Finder, it disappears there, but reappears in every other app.

Imprint | Privacy Policy