ChatGPT shortcut not replacing text

I'm unable to get the ChatGPT shortcut to replace text. I've tried it in multiple different applications. I'm using my own API key. For a while it wasn't opening the window to ask for my command even with the setting checked, but now it will, it just won't change any text.

Device information:

  • Type of Mac: Macbook M1 Max 16-inch, 2021
  • macOS version: 13.2.1 (22D68)
  • BetterTouchTool version: 4.068

are you using a special keyboards layout? BTT uses cmd+v to. replace the text, which can fail for custom keyboard layouts

I am not. I’ve also tried manually pasting afterwards but it doesn’t do anything.

weird, I don't know what could cause this as it seems to work on many systems. Did you grant BTT the Accessibility permissions in System Settings?

Are you trying to use it in a specific app or across various apps?

Yeah, I had similar thoughts. Accessibility settings seemed fine and I tried it in VS Code and Apple Notes.

Is the a log file I can look at?

This same thing happens to me. I noticed that it only happens when I use my own chatGPT API key, if I don't use an API key it works fine.
I confirmed in my API page in ChatGPT that the key is used when I place it in BTT but it just does not change any of the selected text.