Changing keyboard layout modifies keyboard shortcut mappings in BTT

Describe the bug

I'm currently in the process of learning the Dvorak keyboard layout (actually, the french one called "Bépo"), and when switching to this layout all my mappings in BTT are automatically modified ("trigger other keyboard shortcut"). For instance, I mapped the four finger swipe down to CMD-W to be able to close windows quickly. When switching to Dvorak this gesture doesn't work anymore because the target keyboard shortcut gets changed automatically to CMD-É. I can't see why this would be the expected behaviour, so I'm filling this as a bug.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Keyboard shortcuts

Screenshots

Not applicable.

Device information:

  • Type of Mac: MBP 2015
  • macOS version: Mojave
  • BetterTouchTool version: 2.717

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

None.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Unfortunately BetterTouchTool only records the physical location of the keys (everything else is very complicated and error prone on macOS). Thus changing layouts will break the shortcuts.

If you want you can create different presets for different layouts and switch between them on demand.

Unfortunately I won't be able to fix this (although it would be nice).

This will be quite a job for me to re-map all those keys (I've got a lot haha) but I totally understand.

Thanks for taking the time.

The current alpha v2.826 adds an experimental option that allows to auto-adapt shortcuts:

However they would need to be re-recorded as the old database doesn't contain all necessary information.

1 Like

Hey that's cool - thanks for letting me know !

Hey, just tried it with the french dvorak layout - it works fine !

Thanks !