Can't import my saved preset without replacing newly imported Caliguvara

I'm new to BTT. I've had both my presets and Caliguvara 3 installed together for a few days, but got myself in a bit of a muddle today with the updates to Caliguvara. So I exported my presets, cleaned everything out and reinstalled C3, followed by its updates. I then went to reimport my presets but now I get a message asking if I'm sure because it will replace C3. Or if I remove C3 and put mine in, then attempt to reimport C3, I get the equivalent message. What have I done? This didn't happen a few days ago.

Screenshots

Device information:

  • MacBook Pro 2019
  • macOS version: 10.14.6
  • BetterTouchTool version: 3.207 (1384)
1 Like

Hey,
First of all, I'm happy to hear that you use the preset :slightly_smiling_face: It's not the biggest one of the community, so it's nice to see when someone likes it :slightly_smiling_face:

I encountered a similar problem when I was importing a copy of my "personal" C Version in order to make the last changes for Public Release here (w/o going into details, I updates the codes in order to work with Catalina, got rid of iCallBuddy, iStat Menu etc, still fight with the AirPods Widget and the Language Picker though).

I think BTT just found similarities in both presets (was Tony based on C3? Or did you rename the preset file in the finder?)
What I'd do:

  • Export your Tony Preset (save it to the desktop feg)
  • Export your C3 Preset (save it to the desktop feg)
    So now you have a backup of all your files whatever happens.
  • And now try to see what happens if you import C3 and replace Tony.
    Best case scenario: Everything is perfect, just as you wanted
    Worst case scenario: big with in your TouchBar, in which case you just delete the presets from BTT and import your backups.

Let me know if this helped :slightly_smiling_face:

1 Like

Thanks for the reply. Whatever I try, I can't import both. I tried deleting default, but Tony was still overwritten. I tried renaming Tony to Default with the same result. I've reinstalled BTT, but it's made no difference.

When I proceed with and import-and-replace I get this:

Interestingly, when I import C3 replacing Tony, the top-right corner of BTT still says "Preset: Tony"

Ok. Rename the present tony preset to "TONY1". Export the new preset. Delete it from BTT.
Import the C3. Rename it to "C4Tony". Export this. Delete it from BTT.
Now import the TONY1 and C4Tony, it should work now!

If not, I'll send you the prerelease version of the Catalina compatible Preset.

Thanks for your help. I'm afraid it didn't work.

Problem is if your exported presets contain the same elements (with the same UUID) multiple times. For example if you moved one item from your Caliguvara preset to your own preset, BTT will currently think this is a modified version of Caliguvara and therefore try to replace that.

Possibly post your presets, than I can check them.

2 Likes

Ah, yes. I think I did move some items across. I should be able to track the issue down now.

I created a new preset for each app that I'd used within my Tony preset, and copied the items across rather than moving them, then exported them and deleted everything. Then I imported my modified C3 and each of the other apps. All is now working again! I just need to reimport the C3 updates again. Thanks for your help.
Tony

1 Like
Imprint | Privacy Policy