Can't add BTT to Control Strip M2 MacBook Pro

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
I have an M2 MacBook Pro running Ventura 13.1. Icannot get the BTT icon onto the Touch Bar so I can switch between the Mac Control Strip and the BTT one. At the moment the only thing that works is going into settings and ticking/unticking the Show macOS Control Strip box. The Show BetterTouchTool Icon in Control Strip does nothing. I saw an earlier report of something similar in Monterey 12.2 but that was solved by an update. I was hopeful for the latest update to BTT but nothing changed. I posted this on the forum but have had no replies so am reporting it as a bug.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro Touch Bar

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: M2 MacBook Pro
  • macOS version: Ventura 13.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one"). 4.017

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
The only way I can access the BTT icons in the Control Strip is to go into Settings and deselect Show macOS Control Strip. This is a new MacBook I am building from clean so there is no real legacy stuff on there to get in the way.

Does any other app block the space for the custom button (only the leftmost one can be replaced by BTT).

It seems to work fine here with 13.2

No, there is space on the Touch Bar and just in case I removed a couple of the Apple ones to make sure there was room. I’ve yet to upgrade to 13.2 - I always leave it for a few weeks after public release to make sure there are no killer bugs being reported.